Formatting Designs Guide

General recommendations

Whenever possible we recommend that you upload a vector version of your design such as SVG, AI or EPS. If you upload a raster image such as JPG, PNG or GIF, we will automatically convert it to a vector and reduce it to one color. 

Vector images provide better quality printing because you can scale them up to any size without seeing jagged edges. This is how we can produce your item at the highest level of fidelity.

For now, designs in the Editor can only have one color. If you are looking to print multi-color designs please contact us. If you need finer control on how the colors are reduced, we recommend using image editing software such as Photoshop or Illustrator prior to upload.

We also offer editable dieline files to create more advanced designs on our packaging products. These are templates that allow you to precisely place your artwork on the product.


Uploading a JPG, PNG or GIF (raster artwork)

Drag and drop your file into the Editor and we will automatically convert it into a vector. We accept standard image formats including JPG, PNG and GIF. For best results we recommend using high resolution, high contrast images such as logos and text. Photography is generally not suited for vector-based graphics.


Uploading an SVG, AI, EPS or PDF (vector artwork)

Vector designs on Lumi must be relatively simple to be compatible with our manufacturing processes. For best results your vector file should be made up of black filled shapes, no strokes. All text must be converted to outlines. We recommend outputting your file in SVG format.

Our image processor will automatically simplify complex vector files. If you are encountering missing or blacked out elements try following the steps below using Adobe Illustrator or the free Inkscape vector editor.


Converting fonts and shapes to outlines in Adobe Illustrator

If you are starting from a vector file such as EPS or AI, you may need to simplify the design for use on Lumi.

  1. Simplify your design to one color (choose black for best results).
  2. Remove unnecessary strokes.
  3. Convert text to outlines by using “Select > All” then “Type > Create Outlines”.
  4. Convert all elements to simple shapes using “Object > Expand Appearance” then “Object > Expand”.
  5. Finally “Select > All” then open the Pathfinder panel using “Window > Pathfinder”. Under Shape Modes click “Unite”.
  6. From the menu bar click “File > Save As” and choose SVG. Save your file using the default SVG options.
  7. You’re done! The file is now ready to upload to Lumi.